Trying to play TGM 3 in 2021 on Windows 10

Thread in 'Discussion' started by Radux Sepul, 26 Jul 2021.

  1. Hi guys, I think because of a windows update, TGM 3 is not capped on fps. The game worked fine before, but now it doesn't work properly, I tried everything to fix this, I tried turning on vsync on the nvidia control panel, downloading the game again, capping fps with an external tool (reference http://tetrisonline.pl/forum/viewtopic.php?f=5&t=9 ) but nothing has worked, any help?

    Specs: Intel i3-8100
    20 GB RAM
    NVIDIA 1050 TI
    Windows 10 version 21h1
     
  2. thank you for sharing radux o/ that's unfortunate about your setup running wild. of course this is not a solution, but please allow me to add that games like shiromino, and cambridge are also great, similar, and wont have this problem.
     
  3. Not sure if it will help, but I've been playing tgm3 via TeknoParrot for a while, saved me all the hassles from running the original stuff directly in windows.
     
  4. Zaphod77

    Zaphod77 Resident Misinformer

    Might it be using the integrated graphics instead? may need to force the nvidia card.
     
  5. Does the game play sound effects? When I use TeknoParrot, the only sound I get is music. I can get sound effects when running through TypeXtra, but not TeknoParrot.
     
  6. TGM3 really likes Vsync and it will sync to your monitor, which can cause issues if it is not set to 60Hz.

    First of all, are you using altinput (tgm3_launcher.exe) or typex_loader.exe?
    Altinput is strongly recommended.
    Try tgm3_launcher.exe with and without fullscreen (in tgm3.cfg), for good measure.

    BTW in case that doesn't work, on my other Nvidia PC, I was able to fix this problem (play at 60fps on a 120Hz display) by creating a profile with the Nvidia Control Panel for game.exe and tgm3_launcher.exe and then using Nvidia Profile Inspector to edit the profiles as this shows options that are hidden in the Nvidia panel, most notably which frame limiter version to use. I remember that only one of them worked with TGM3 but unfortunately it was a long time ago so you're gonna have to run some experiments. You have to close the game after saving the profile for the changes to take place, but it should be pretty fast to test all three frame limiters. Limit should of course be 60 FPS

    If you don't have an Nvidia card and/or nothing else works, you can set your monitor to 60Hz before playing. I used to do this for a bunch of really old games with this issue. For extra laziness there is software like DisplayFusion (that you can also get on Steam) that allows you to assign a keyboard hotkey to a profile of resolution and refresh rate, so you can Ctrl-Alt-Something before opening the game and Ctrl-Alt-Whatever after you close the game without having to open Windows settings.
    I'm sure you could throw together a powershell script or something if you don't wanna pay for it, or just use Windows display settings menu.

    these were the softer solutions, the actual fix is playing tgm2
     
    Last edited: 11 Oct 2021 at 7:16 AM
  7. Yup, it works perfectly even on my old crappy laptop
     

Share This Page